Tips

【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題Ⅱ】Part 4
2018.11.12

【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題Ⅱ】Part 4

【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題Ⅱ】Part 4

CCNAの取得を目指している方へ向けて、試験範囲の対策問題を作成してみました。
今回はVLANに関するシミュレーション問題を作成しました!
ルータの設定とスイッチの設定の両方を見て判断しなければいけないので大変ですが、解いてみてください!
↓前回のシミュレーション問題編の問題はコチラ!
【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題】Part 1
【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題】Part 2
【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題】Part 3
【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題】Part 4

下図のようにネットワークが構成されています。
それぞれの設定を確認して次の問題に答えてください。


Router1 show running-configの結果
Router1#show running-config
Building configuration…

Current configuration : 1024 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 201.30.45.13 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1.10
encapsulation dot1Q 10
ip address 192.168.10.254 255.255.255.0
ip nat inside
!
interface FastEthernet0/1.20
encapsulation dot1Q 20
ip address 192.168.20.254 255.255.255.0
ip nat inside
!
interface FastEthernet0/1.30
encapsulation dot1Q 30
ip address 192.168.30.254 255.255.255.0
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source list 1 interface FastEthernet0/0
ip classless
!
!
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 1 permit 192.168.20.0 0.0.0.255
access-list 1 permit 192.168.30.0 0.0.0.255
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end

Switch1 show vlanの結果
Switch1#show vlan

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/4, Fa0/5, Fa0/6, Fa0/7
Fa0/8, Fa0/9, Fa0/10, Fa0/11
Fa0/12, Fa0/13, Fa0/14, Fa0/15
Fa0/16, Fa0/17, Fa0/18, Fa0/19
Fa0/20, Fa0/21, Fa0/22, Fa0/23
Fa0/24
10 VLAN0010 active Fa0/1
20 VLAN0020 active Fa0/2
30 VLAN0030 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1 enet 100001 1500 – – – – – 0 0
10 enet 100010 1500 – – – – – 0 0
20 enet 100020 1500 – – – – – 0 0
30 enet 100030 1500 – – – – – 0 0
1002 fddi 101002 1500 – – – – – 0 0
1003 tr 101003 1500 – – – – – 0 0
1004 fdnet 101004 1500 – – – ieee – 0 0
1005 trnet 101005 1500 – – – ibm – 0 0

Remote SPAN VLANs
——————————————————————————

Primary Secondary Type Ports
——- ——— —————– ——————————————

Switch1 show running-configの結果
Switch1#show running-config
Building configuration…

Current configuration : 1048 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch1
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
!
interface FastEthernet0/2
switchport access vlan 20
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

Switch2のshow vlanの結果
Switch2#show vlan

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24
10 VLAN0010 active Fa0/1
20 VLAN0020 active Fa0/2
30 VLAN0030 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1 enet 100001 1500 – – – – – 0 0
10 enet 100010 1500 – – – – – 0 0
20 enet 100020 1500 – – – – – 0 0
30 enet 100030 1500 – – – – – 0 0
1002 fddi 101002 1500 – – – – – 0 0
1003 tr 101003 1500 – – – – – 0 0
1004 fdnet 101004 1500 – – – ieee – 0 0
1005 trnet 101005 1500 – – – ibm – 0 0

Remote SPAN VLANs
——————————————————————————

Primary Secondary Type Ports
——- ——— —————– ——————————————

Switch2のshow running-configの結果
Switch2#show running-config
Building configuration…

Current configuration : 1094 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch2
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
!
interface FastEthernet0/2
switchport access vlan 20
!
interface FastEthernet0/3
switchport mode trunk
!
interface FastEthernet0/4
switchport mode trunk
!
interface FastEthernet0/5
switchport mode trunk
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

Switch3のshow vlanの結果
Switch3#show vlan

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
10 VLAN0010 active Fa0/1
20 VLAN0020 active
30 VLAN0030 active Fa0/2, Fa0/3
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1 enet 100001 1500 – – – – – 0 0
10 enet 100010 1500 – – – – – 0 0
20 enet 100020 1500 – – – – – 0 0
30 enet 100030 1500 – – – – – 0 0
1002 fddi 101002 1500 – – – – – 0 0
1003 tr 101003 1500 – – – – – 0 0
1004 fdnet 101004 1500 – – – ieee – 0 0
1005 trnet 101005 1500 – – – ibm – 0 0

Remote SPAN VLANs
——————————————————————————

Primary Secondary Type Ports
——- ——— —————– ——————————————

Switch3のshow running-configの結果
Switch3#show running-config
Building configuration…

Current configuration : 1076 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch3
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport access vlan 30
!
interface FastEthernet0/3
switchport access vlan 30
!
interface FastEthernet0/4
switchport mode trunk
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

問題1

スイッチ1~3とRouter1に設定を追加して、LAN内の全てのPC同士が通信を行うことが出来る状態にします。現在のそれぞれの機器の状態を確認して、追加で必要なコマンドはどれですか。3つ選択してください。

  1. Router(config)#interface FastEthernet 0/1
    Router(config-if)#no shutdown
  2. Router(config)#vlan 10,20,30
  3. Switch1(config)#interface FastEthernet 0/1
    Switch1(config-if)#ip address 192.168.10.253 255.255.255.0
  4. Switch1(config)#interface FastEthernet 0/3
    Switch1(config-ig)#switchport mode trunk
  5. Switch2(config)#vlan routing
  6. Switch3(config)#interface FastEthernet 0/1
    Switch3(config-if)#switchport access vlan 10
  7. Switch3(config)#interface FastEthernet0/4
    Switch3(config-if)#switchport mode access
問題1の解答と解説を表示

解答)A、D、F

スイッチとルータを使用した構成では、スイッチと端末(PCなど)を接続するポートはアクセスポートの設定をして、特定のVLANに所属させます。また、スイッチとルータを接続するポートや、スイッチ同士を接続するポートはトランクポートの設定を行います。ルーティングをするためには、レイヤ3スイッチやルータなどのレイヤ3機器が必要になり、ルータとスイッチをトランクポートで接続する場合、それぞれのVLANの通信を受け取るサブインターフェースを作成し、そこにIPアドレス等の設定を行います。サブインターフェースを作成する大元のインターフェースにはIPアドレスの設定は行いませんが、ポートを有効化する必要はあります。

問題2

ルータにNAPTの設定を行い、LAN内の全てのPCはWANと通信する際に、送信元IPアドレスをルータのWAN側のインターフェースのアドレスに変換するように設定を行います。現在のそれぞれの機器の状態を確認して、追加で必要なコマンドはどれですか。2つ選択してください。

  1. Router1(config)#ip nat napt enable
  2. Router1(config)#ip nat inside source vlan 10,20,30 interface FastEthernet0/0 overload
  3. Router1(config)#ip nat inside source list 1 interface FastEthernet0/0 overload
  4. Router1(config)#interface FastEthernet 0/0.30
    Router1(config-subif)#ip nat inside
  5. Router1(config)#interface FastEthernet 0/0.30
    Router1(config-subif)#ip nat outside
問題2の解答と解説を表示

解答)C、D

NAPTの設定はまずアクセスリストを作成し、どの送信元IPアドレスからの通信を変換の対象にするかを指定します。次に、アクセスリストとインターフェースを紐付けて、「overload」キーワードを付けて設定を行います。また、それぞれのインターフェースに内側(LAN側)か外側(WAN側)かの設定をそれぞれip nat inside/ip nat outsideコマンドで設定します。ルータの設定を見ると、アクセスリストは問題なく作成されています。ですが、アクセスリストとインターフェースの紐づけのコマンドに「overload」が入っていません。また、インターフェースの設定を確認すると、Fa0/1.30にip nat insideが設定されていません。よって、正解はC、Dになります。

Recent News

Recent Tips

Tag Search