Tips

【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題Ⅱ】Part 2
2018.11.05

【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題Ⅱ】Part 2

【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題Ⅱ】Part 2

CCNAの勉強をしている方へ向けて、試験範囲の対策問題を作成してみました。
今回はVLANに関するシミュレーション問題を作成しました!
ルータの設定とスイッチの設定の両方を見て判断しなければいけないので大変ですが、解いてみてください!
↓前回のシミュレーション問題編の問題はコチラ!
【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題】Part 1
【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題】Part 2
【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題】Part 3
【CCNA試験対策問題】ネットワークの基礎から学んでいこう!【シミュレーション問題】Part 4

下図のようにネットワークが構成されています。
それぞれの設定を確認して次の問題に答えてください。

Router1 show running-configの結果
Router1#show running-config
Building configuration…

Current configuration : 1024 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 201.30.45.13 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
ip nat inside
!
interface FastEthernet0/1.10
encapsulation dot1Q 10
ip address 192.168.10.254 255.255.255.0
!
interface FastEthernet0/1.20
encapsulation dot1Q 20
ip address 192.168.20.254 255.255.255.0
!
interface FastEthernet0/1.30
encapsulation dot1Q 30
ip address 192.168.30.254 255.255.255.0
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
!
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 1 permit 192.168.20.0 0.0.0.255
access-list 1 permit 192.168.30.0 0.0.0.255
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end

Switch1 show vlanの結果
Switch1#show vlan

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/4, Fa0/5, Fa0/6, Fa0/7
Fa0/8, Fa0/9, Fa0/10, Fa0/11
Fa0/12, Fa0/13, Fa0/14, Fa0/15
Fa0/16, Fa0/17, Fa0/18, Fa0/19
Fa0/20, Fa0/21, Fa0/22, Fa0/23
Fa0/24
10 VLAN0010 active Fa0/1
20 VLAN0020 active Fa0/2
30 VLAN0030 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1 enet 100001 1500 – – – – – 0 0
10 enet 100010 1500 – – – – – 0 0
20 enet 100020 1500 – – – – – 0 0
30 enet 100030 1500 – – – – – 0 0
1002 fddi 101002 1500 – – – – – 0 0
1003 tr 101003 1500 – – – – – 0 0
1004 fdnet 101004 1500 – – – ieee – 0 0
1005 trnet 101005 1500 – – – ibm – 0 0

Remote SPAN VLANs
——————————————————————————

Primary Secondary Type Ports
——- ——— —————– ——————————————

Switch1 show running-configの結果
Switch1#show running-config
Building configuration…

Current configuration : 1048 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch1
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
!
interface FastEthernet0/2
switchport access vlan 20
!
interface FastEthernet0/3
switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

Switch2 show vlanの結果
Switch2#show vlan

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24
10 VLAN0010 active Fa0/1
20 VLAN0020 active Fa0/2
30 VLAN0030 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1 enet 100001 1500 – – – – – 0 0
10 enet 100010 1500 – – – – – 0 0
20 enet 100020 1500 – – – – – 0 0
30 enet 100030 1500 – – – – – 0 0
1002 fddi 101002 1500 – – – – – 0 0
1003 tr 101003 1500 – – – – – 0 0
1004 fdnet 101004 1500 – – – ieee – 0 0
1005 trnet 101005 1500 – – – ibm – 0 0

Remote SPAN VLANs
——————————————————————————

Primary Secondary Type Ports
——- ——— —————– ——————————————

Switch2 show running-configの結果
Switch2#show running-config
Building configuration…

Current configuration : 1094 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch2
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
!
interface FastEthernet0/2
switchport access vlan 20
!
interface FastEthernet0/3
switchport mode trunk
!
interface FastEthernet0/4
switchport mode trunk
!
interface FastEthernet0/5
switchport mode trunk
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

Switch3 show vlanの結果
Switch3#show vlan

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
10 VLAN0010 active Fa0/1
20 VLAN0020 active
30 VLAN0030 active Fa0/2, Fa0/3, Fa0/4
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1 enet 100001 1500 – – – – – 0 0
10 enet 100010 1500 – – – – – 0 0
20 enet 100020 1500 – – – – – 0 0
30 enet 100030 1500 – – – – – 0 0
1002 fddi 101002 1500 – – – – – 0 0
1003 tr 101003 1500 – – – – – 0 0
1004 fdnet 101004 1500 – – – ieee – 0 0
1005 trnet 101005 1500 – – – ibm – 0 0

Remote SPAN VLANs
——————————————————————————

Primary Secondary Type Ports
——- ——— —————– ——————————————

Switch3 show running-configの結果
Switch3#show running-config
Building configuration…

Current configuration : 1076 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch3
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
!
interface FastEthernet0/2
switchport access vlan 30
!
interface FastEthernet0/3
switchport access vlan 30
!
interface FastEthernet0/4
switchport access vlan 30
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

問題1

LAN内のPCがインターネットに接続できていません。この問題の原因は何ですか。

  1. NATのoutsideインターフェースの設定に誤りがある。
  2. NATのinsideインターフェースの設定に誤りがある。
  3. NATで使用しているアクセスリストに誤りがある。
  4. ポートがシャットダウンされている。
  5. ルーティングの設定がされていない。
問題1の解答と解説を表示

解答)B

この問題では、NATの設定が正しいかどうかを出題しています。複数のホストが接続されているので、NATオーバーロードを使用しています。NATの設定で確認すべき項目は、①アクセスリストで指定するネットワークが正しいか、②インターフェースでのinside,outsideの設定が間違っていないか、③アクセスリストと変換先のインターフェース(またはアドレスプール)の対応が間違っていないかの3つです。この問題で注目する点は、サブインターフェースとNATを同時に設定する際の設定方法です。サブインターフェースとNATのinsideを同時に設定する場合、ip nat insdeコマンドはサブインターフェースで設定する必要があります。Router1のshow running-configを見ると、サブインターフェースではなく、大元のインターフェースにip nat insideコマンドが設定されていることが分かります。よって、Bが正解になります。

問題2

Switch1に接続されたVLAN10に所属するPCとSwitch3に接続されたVLAN10に所属するPCの間で通信ができていません。この問題の原因は何ですか。

  1. Switch1のポートがシャットダウンされている。
  2. Switch1のVLANの設定に誤りがある。
  3. Switch2のVLANの設定に誤りがある。
  4. Switch3のポートがシャットダウンされている。
  5. Switch3のポートのモードの設定に誤りがある。
問題2の解答と解説を表示

解答)E

それぞれのスイッチの設定を見ると、Switch3のFa0/4にswitchport access vlan 30という設定が入っていることが分かります。よって、Switch3とSwitch2間はVLAN30のアクセスリンクになっており、VLAN30の通信しか通ることが出来ないことが分かります。これが通信できていない原因だと考えられます。

Recent News

Recent Tips

Tag Search