【CCNA対策】EIGRPのネイバー関係が築けていないパターン5選【その3】


【CCNA対策】EIGRPのネイバー関係が築けていないパターン5選【その3】

CCNAの試験範囲にも含まれているEIGRP。拡張ディスタンスベクタ型に分類されるEIGRPでは、
OSPFと同様にまず隣接ルータとネイバー関係を築いてからその後に情報交換を行います。
そのため何よりもまず先にネイバー関係が築けていないとルーティングテーブルは完成しません。
CCNAで覚えておくべきネイバー関係を築けない5パターンを問題形式で見ていきましょう。

2問ずつ3回に分けて出題していきます。今回は第3回目です。

【構成図と問題】

以下のようにルータが3台接続されています。
(画像をクリックすると別タブで拡大画像が表示されます。)

このときR1とR2がネイバー関係を築けていません。
※今回はR1とR2だけです
原因を以下のコンフィグの中から見つけ出し、修正コマンドを述べてください。

【R1のshowコマンド抜粋】

show running-config

R1#show running-config
Building configuration...

Current configuration : 839 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 ip address 192.168.100.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
!
router eigrp 100
 network 192.168.10.0
 no auto-summary
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.100.0/24 is directly connected, FastEthernet0/0

show ip interface brief

R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.100.1   YES manual up                    up  
FastEthernet1/0            unassigned      YES unset  administratively down down

show ip protocols

Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.10.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170

【R2のshowコマンド抜粋】

show running-config

R2#show running-config
Building configuration...

Current configuration : 904 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 ip address 192.168.100.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 172.16.1.2 255.255.255.0
 duplex auto
 speed auto
!
!
router eigrp 100
 network 172.16.1.0 0.0.0.255
 network 192.168.100.0
 no auto-summary
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet1/0
C    192.168.100.0/24 is directly connected, FastEthernet0/0

show ip interface brief

R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.100.2   YES manual up                    up  
FastEthernet1/0            172.16.1.2      YES manual up                    up  

show ip protocols

R2#show ip protocols
Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    172.16.1.0/24
    192.168.100.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    (this router)         90      00:38:47
  Distance: internal 90 external 170

【R3のshowコマンド抜粋】

show running-config

R3#show running-config
Building configuration...

Current configuration : 866 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 172.16.1.1 255.255.255.0
 duplex auto
 speed auto
!
!
router eigrp 100
 network 172.16.1.0 0.0.0.255
 no auto-summary
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet1/0
D    192.168.100.0/24 [90/30720] via 172.16.1.2, 00:06:50, FastEthernet1/0

show ip interface brief

R3#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet1/0            172.16.1.1      YES manual up                    up  

show ip protocols

R3#show ip protocols
Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    172.16.1.0/24
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.1.2            90      00:06:52
  Distance: internal 90 external 170

【R1とR2がネイバーを築けていない問題の解答と解説】

R1とR2の両ルータでインターフェイスの状態を確認すると、どちらのルータの
インターフェイスもup/upになっていることが読み取れます。

次にEIGRPの設定を確認します。するとR1ではAS番号100で設定されていますが、
networkコマンドで指定されているネットワークに誤りがあることが分かります。

router eigrp 100
 network 192.168.10.0
 no auto-summary

EIGRPのnetworkコマンドでは、その範囲に含まれているインターフェイスから
EIGRPの各種パケットを送信します。R1のFa0/0のIPアドレスは192.168.100.1ですので、
このnetworkコマンドの範囲に含まれていません。
そのためFa0/0からHelloパケットが送られず、R2とネイバー関係を築くことができません。

【修正コマンド】

R1(config)#router eigrp 100
R1(config-router)#no network 192.168.10.0
R1(config-router)#network 192.168.100.0 0.0.0.255

※ワイルドカードマスク0.0.0.255は省略することもできます。

  • このエントリーをはてなブックマークに追加

PAGE TOP