【CCNA対策】EIGRPのネイバー関係が築けていないパターン5選【その2】


【CCNA対策】EIGRPのネイバー関係が築けていないパターン5選【その2】

CCNAの試験範囲にも含まれているEIGRP。拡張ディスタンスベクタ型に分類されるEIGRPでは、
OSPFと同様にまず隣接ルータとネイバー関係を築いてからその後に情報交換を行います。
そのため何よりもまず先にネイバー関係が築けていないとルーティングテーブルは完成しません。
CCNAで覚えておくべきネイバー関係を築けない5パターンを問題形式で見ていきましょう。

2問ずつ3回に分けて出題していきます。今回は第2回目です。

【構成図と問題】

以下のようにルータが3台接続されています。
(画像をクリックすると別タブで拡大画像が表示されます。)

このときR1とR2、R2とR3がネイバー関係を築けていません。
原因を以下のコンフィグの中から見つけ出し、修正コマンドを述べてください。

【R1のshowコマンド抜粋】

show running-config

R1#show running-config
Building configuration...

Current configuration : 862 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 ip address 192.168.100.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
!
router eigrp 100
 network 192.168.100.0
 no auto-summary
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.100.0/24 is directly connected, FastEthernet0/0

show ip interface brief

R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.100.1   YES manual up                    up  
FastEthernet1/0            unassigned      YES unset  administratively down down

show ip protocols

R1#show ip protocols
Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.100.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.100.2         90      00:02:58
  Distance: internal 90 external 170

【R2のshowコマンド抜粋】

show running-config

R2#show running-config
Building configuration...

Current configuration : 958 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 ip address 192.168.100.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 172.16.1.2 255.255.255.0
 duplex auto
 speed auto
!
!
router eigrp 100
 passive-interface FastEthernet0/0
 network 172.16.1.0 0.0.0.255
 network 192.168.100.0
 no auto-summary
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet1/0
C    192.168.100.0/24 is directly connected, FastEthernet0/0

show ip interface brief

R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.100.2   YES manual up                    up  
FastEthernet1/0            172.16.1.2      YES manual up                    up  

show ip protocols

R2#show ip protocols
Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    172.16.1.0/24
    192.168.100.0
  Passive Interface(s):
    FastEthernet0/0
  Routing Information Sources:
    Gateway         Distance      Last Update
    (this router)         90      00:25:44
  Distance: internal 90 external 170

【R3のshowコマンド抜粋】

show running-config

R3#show running-config
Building configuration...

Current configuration : 913 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 172.16.1.1 255.255.255.0
 duplex auto
 speed auto
!
!
router eigrp 100
 network 172.16.1.0 0.0.0.255
 metric weights 0 1 1 1 0 0
 no auto-summary
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet1/0

show ip interface brief

R3#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet1/0            172.16.1.1      YES manual up                    up  

show ip protocols

R3#show ip protocols
Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=1, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    172.16.1.0/24
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.1.2            90      00:01:05
  Distance: internal 90 external 170

【R1とR2がネイバーを築けていない問題の解答と解説】

R1とR2のshow ip interface briefコマンドを確認してみると、両ルータとも
インターフェイスはup/upになっていることが分かります。

次にEIGRPの設定を確認します。両ルータともAS番号が100で設定されているため、
AS番号に問題はありませんが、R2にパッシブインターフェイスの設定がされている
のが確認できます。

router eigrp 100
 passive-interface FastEthernet0/0
 network 172.16.1.0 0.0.0.255
 network 192.168.100.0
 no auto-summary

パッシブインターフェイスの設定がされていると、そのインターフェイス方向に
EIGRPのパケットを送信しなくなります。つまりHelloパケットも送信しなく
なるため、ネイバー関係を築くことができなくなります。

パッシブインターフェイスの設定は、PCなどの端末と接続されているインターフェイス側
で設定するもので、ルータと接続しているインターフェイスで設定してはいけません。

【修正コマンド】

R2(config)#router eigrp 100
R2(config)#no passive-interface FastEthernet0/0

【R2とR3がネイバーを築けていない問題の解答と解説】

先ほどと同様にR2とR3のインターフェイスを確認してみると、どちらもup/upになっていて
問題ありません。

次にEIGRPの設定を確認します。するとR3にmetric weightsコマンドが設定されている
ことが分かります。このコマンドはEIGRPのメトリック計算に用いるK値の値を変更するコマンド
です。

router eigrp 100
 network 172.16.1.0 0.0.0.255
 metric weights 0 1 1 1 0 0
 no auto-summary

数値が6個並んでいますが、2つ目の数値からがK1~K5までの値となります。
つまり、K1=1、K2=1、K3=1、K4=0、K5=0と設定されています。
R2にはこのコマンドが設定されていませんので、デフォルトのK1=1、K2=0、K3=1、K4=0、K5=0
になっていることが読み取れます。

EIGRPではAS番号とK値が一致していなければネイバー関係を築くことができないため、
この部分に設定の誤りがあると読み取れます。

また、設定されているK値は、show ip protocolsコマンドでも確認が可能です。

R3#show ip protocols
Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=1, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    172.16.1.0/24
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.1.2            90      00:01:05
  Distance: internal 90 external 170

の7行目の部分にK1からK5までの値が記述されています。

【修正コマンド】

R3(config)#router eigrp 100
R3(config)#metric weights 0 1 0 1 0 0
  • このエントリーをはてなブックマークに追加

PAGE TOP