【CCNA対策】EIGRPのネイバー関係が築けていないパターン5選【その1】


【CCNA対策】EIGRPのネイバー関係が築けていないパターン5選【その1】

CCNAの試験範囲にも含まれているEIGRP。拡張ディスタンスベクタ型に分類されるEIGRPでは、
OSPFと同様にまず隣接ルータとネイバー関係を築いてからその後に情報交換を行います。
そのため何よりもまず先にネイバー関係が築けていないとルーティングテーブルは完成しません。
CCNAで覚えておくべきネイバー関係を築けない5パターンを問題形式で見ていきましょう。

2問ずつ3回に分けて出題していきます。今回は第1回目です。

【構成図と問題】

以下のようにルータが3台接続されています。
(画像をクリックすると別タブで拡大画像が表示されます。)

このときR1とR2、R2とR3がネイバー関係を築けていません。
原因を以下のコンフィグの中から見つけ出し、修正コマンドを述べてください。

【R1のshowコマンド抜粋】

show running-config

R1#show running-config
Building configuration...

Current configuration : 872 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 ip address 192.168.100.1 255.255.255.0
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
!
router eigrp 100
 network 192.168.100.0
 no auto-summary
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

show ip interface brief

R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.100.1   YES manual administratively down down
FastEthernet1/0            unassigned      YES unset  administratively down down

show ip protocols

R1#show ip protocols
Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.100.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.100.2         90      00:07:26
  Distance: internal 90 external 170

【R2のshowコマンド抜粋】

show running-config

R2#show running-config
Building configuration...

Current configuration : 904 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 ip address 192.168.100.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 172.16.1.2 255.255.255.0
 duplex auto
 speed auto
!
!
router eigrp 100
 network 172.16.1.0 0.0.0.255
 network 192.168.100.0
 no auto-summary
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet1/0

show ip interface brief

R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.100.2   YES manual up                    down  
FastEthernet1/0            172.16.1.2      YES manual up                    up  

show ip protocols

R2#show ip protocols
Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    172.16.1.0/24
    192.168.100.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    (this router)         90      00:07:41
  Distance: internal 90 external 170

【R3のshowコマンド抜粋】

show running-config

R3#show running-config
Building configuration...

Current configuration : 865 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 172.16.1.1 255.255.255.0
 duplex auto
 speed auto
!
!
router eigrp 10
 network 172.16.1.0 0.0.0.255
 no auto-summary
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet1/0

show ip interface brief

R3#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet1/0            172.16.1.1      YES manual up                    up  

show ip protocols

R3#show ip protocols
Routing Protocol is "eigrp 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 10
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    172.16.1.0/24
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170

【R1とR2がネイバーを築けていない問題の解答と解説】

R1とR2のshow ip routeを見てみると、両ルータに192.168.100.0/24のネットワークが
表示されていません。
次にそれぞれのルータでshow ip interface briefコマンドを確認してみます。
するとR1のFa0/0ではadministratively down/downとなっていて、R2のFa0/0では
up/downとなっています。

この結果から、R1のFa0/0でno shutdownを実行しておらず、shutdown状態であることが
分かります。
実際にR1のshow running-configでFa0/0の部分を見てみると、

interface FastEthernet0/0
 ip address 192.168.100.1 255.255.255.0
 shutdown
 duplex auto
 speed auto

と、シャットダウンされています。

【修正コマンド】

R1(config)#interface FastEthernet 0/0
R1(config-if)#no shutdown

【R2とR3がネイバーを築けていない問題の解答と解説】

R2とR3の両ルータでshow ip interface briefコマンドを確認してみると、
どちらのルータのFa1/0もup/upになっていて通信できる状態であることが
確認できます。

次にEIGRPの設定を確認すると、R3ではAS番号が10で設定されていることが
読み取れます。

router eigrp 10
 network 172.16.1.0 0.0.0.255
 no auto-summary

EIGRPではAS番号が一致していなければネイバー関係を築くことができないため、
この部分に誤りがあることが分かります。

【修正コマンド】

R2(config)#no router eigrp 10
R2(config)#no router eigrp 100
R2(config-router)#network 172.16.1.0 0.0.0.255
R2(config-router)#no auto-summary
  • このエントリーをはてなブックマークに追加

PAGE TOP