【CCNA対策】OSPFのネイバー関係が築けていないパターン10選【その4】


【CCNA対策】OSPFのネイバー関係が築けていないパターン10選【その1】

CCNAの試験範囲にも含まれているOSPF。リンクステート型に分類されるOSPFでは、
まず隣接ルータとネイバー関係を築いてからその後に情報交換を行います。
そのため何よりもまず先にネイバー関係が築けていないとルーティングテーブルは完成しません。
CCNAで覚えておくべきネイバー関係を築けない10パターンを問題形式で見ていきましょう。

2問ずつ5回に分けて出題していきます。今回は第4回目です。

【構成図と問題】

以下のようにルータが3台接続されています。
(画像をクリックすると別タブで拡大画像が表示されます。)

このときR1とR2、R2とR3がネイバー関係を築けていません。
原因を以下のコンフィグの中から見つけ出し、修正コマンドを述べてください。

【R1のshowコマンド抜粋】

show running-config

R1#show running-config
Building configuration...

Current configuration : 1241 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 ip address 192.168.100.1 255.255.255.0
 ip ospf 1 area 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.100.0/24 is directly connected, FastEthernet0/0

show ip interface brief

R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.100.1   YES manual up                    up
FastEthernet1/0            unassigned      YES unset  administratively down down
FastEthernet2/0            unassigned      YES unset  administratively down down
Serial3/0                  unassigned      YES unset  administratively down down

show ip ospf interface

R1#show ip ospf interface
FastEthernet0/0 is up, line protocol is up
  Internet Address 192.168.100.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 192.168.100.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

【R2のshowコマンド抜粋】

show running-config

R2#show running-config
Building configuration...

Current configuration : 1295 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 ip address 192.168.100.2 255.255.255.128
 ip ospf 2 area 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial3/0
 ip address 192.168.200.2 255.255.255.0
 encapsulation ppp
 ip ospf 2 area 0
 serial restart-delay 0
!
!
router ospf 2
 router-id 2.2.2.2
 log-adjacency-changes
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     192.168.100.0/25 is subnetted, 1 subnets
C       192.168.100.0 is directly connected, FastEthernet0/0

show ip interface brief

R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.100.2   YES manual up                    up
FastEthernet1/0            unassigned      YES unset  administratively down down
FastEthernet2/0            unassigned      YES unset  administratively down down
Serial3/0                  192.168.200.2   YES manual up                    down

show ip ospf interface

R2#show ip ospf interface
Serial3/0 is up, line protocol is down
  Internet Address 192.168.200.2/24, Area 0
  Process ID 2, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State DOWN
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
FastEthernet0/0 is up, line protocol is up
  Internet Address 192.168.100.2/25, Area 0
  Process ID 2, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 192.168.100.2
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:03
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

【R3のshowコマンド抜粋】

show running-config

R3#show running-config
Building configuration...

Current configuration : 1241 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial3/0
 ip address 192.168.200.1 255.255.255.0
 ip ospf 3 area 0
 serial restart-delay 0
!
!
router ospf 3
 router-id 3.3.3.3
 log-adjacency-changes
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

show ip interface brief

R3#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet1/0            unassigned      YES unset  administratively down down
FastEthernet2/0            unassigned      YES unset  administratively down down
Serial3/0                  192.168.200.1   YES manual up                    down

show ip ospf interface

R3#show ip ospf interface
Serial3/0 is up, line protocol is down
  Internet Address 192.168.200.1/24, Area 0
  Process ID 3, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State DOWN
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40

【R1とR2がネイバーを築けていない問題の解答と解説】

今までと同様に、R1とR2のFa0/0インターフェイスのIPアドレスと有効化されているかを
show ip interface briefで確認します。すると、両ルータのインターフェイスとも
up/upとなっており、IPアドレスも正しく設定されているように一見見えてしまいます。

しかし、show running-configでFa0/0のIPアドレスを確認してみると、
R1のFa0/0では192.168.100.1/24、R2では192.168.100.2/25となっています。

show ip interface briefではサブネットマスクまで確認をすることができないため、
show running-configで見てみると、サブネットマスクが一致していないことが
分かります。
OSPFではサブネットマスクが一致していることがネイバー関係を築くための条件の一つ
となっているため、この状態ではR1とR2でネイバー関係が築けません。

R1とR2のshow running-configでFa0/0の設定を抜粋します。

R2

interface FastEthernet0/0
 ip address 192.168.100.1 255.255.255.0
 ip ospf 1 area 0
 duplex auto
 speed auto

R3

interface FastEthernet0/0
 ip address 192.168.100.2 255.255.255.128
 ip ospf 2 area 0
 duplex auto
 speed auto

R2のサブネットマスクが誤っていることが分かります。

【修正コマンド】

R2(config)#interface FastEthernet 0/0
R2(config-if)#ip address 192.168.100.2 255.255.255.0

【R2とR3がネイバーを築けていない問題の解答と解説】

両ルータのS3/0インターフェイスの状態を確認します。
すると両ルータともにup/downとなっています。
L2プロトコルの部分に問題があり、OSPFの設定以前にリンクが確立されていない
ことが読み取れます。

次に両ルータのshow running-configコマンドでS3/0インターフェイスを
確認します。

R2

interface Serial3/0
 ip address 192.168.200.2 255.255.255.0
 encapsulation ppp
 ip ospf 2 area 0
 serial restart-delay 0

R3

interface Serial3/0
 ip address 192.168.200.1 255.255.255.0
 ip ospf 3 area 0
 serial restart-delay 0

R2のS3/0ではL2プロトコルがPPPになっていることが読み取れます。
R3にはencapsulationコマンドが設定されていませんので、デフォルトである
HDLCになっていることが分かります。

両インターフェイス間でL2プロトコルが一致していないため、up/downとなり
リンクが確立されていません。

【修正コマンド】

L2プロトコルをPPPに統一する場合、R3の設定を変更する

R3(config)#interface Serial 3/0
R3(config-if)#encapsulation ppp

L2プロトコルをhdlcに統一する場合、R2の設定を変更する

R2(config)#interface Serial 3/0
R2(config-if)#encapsulation hdlc
  • このエントリーをはてなブックマークに追加

PAGE TOP