Tips

【CCNA対策】OSPFのネイバー関係が築けていないパターン10選【その3】

【CCNA対策】OSPFのネイバー関係が築けていないパターン10選【その3】

【CCNA対策】OSPFのネイバー関係が築けていないパターン10選【その1】

CCNAの試験範囲にも含まれているOSPF。リンクステート型に分類されるOSPFでは、
まず隣接ルータとネイバー関係を築いてからその後に情報交換を行います。
そのため何よりもまず先にネイバー関係が築けていないとルーティングテーブルは完成しません。
CCNAで覚えておくべきネイバー関係を築けない10パターンを問題形式で見ていきましょう。

2問ずつ5回に分けて出題していきます。今回は第3回目です。

【構成図と問題】

以下のようにルータが3台接続されています。
(画像をクリックすると別タブで拡大画像が表示されます。)

このときR1とR2、R2とR3がネイバー関係を築けていません。
原因を以下のコンフィグの中から見つけ出し、修正コマンドを述べてください。

【R1のshowコマンド抜粋】

show running-config

R1#show running-config
Building configuration...

Current configuration : 1260 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 ip address 192.168.100.1 255.255.255.0
 ip ospf 1 area 1
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.100.0/24 is directly connected, FastEthernet0/0

show ip interface brief

R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.100.1   YES manual up                    up
FastEthernet1/0            unassigned      YES unset  administratively down down
FastEthernet2/0            unassigned      YES unset  administratively down down
Serial3/0                  unassigned      YES unset  administratively down down

show ip ospf interface

R1#show ip ospf interface
FastEthernet0/0 is up, line protocol is up
  Internet Address 192.168.100.1/24, Area 1
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 192.168.100.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:05
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

【R2のshowコマンド抜粋】

show running-config

R2#show running-config
Building configuration...

Current configuration : 1274 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 ip address 192.168.100.2 255.255.255.0
 ip ospf 2 area 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial3/0
 ip address 192.168.200.2 255.255.255.0
 ip ospf 2 area 0
 serial restart-delay 0
!
!
router ospf 2
 router-id 2.2.2.2
 log-adjacency-changes
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.200.0/24 is directly connected, Serial3/0
C    192.168.100.0/24 is directly connected, FastEthernet0/0

show ip interface brief

R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.100.2   YES manual up                    up
FastEthernet1/0            unassigned      YES unset  administratively down down
FastEthernet2/0            unassigned      YES unset  administratively down down
Serial3/0                  192.168.200.2   YES manual up                    up

show ip ospf interface

R2#show ip ospf interface
FastEthernet0/0 is up, line protocol is up
  Internet Address 192.168.100.2/24, Area 0
  Process ID 2, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 192.168.100.2
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:03
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
Serial3/0 is up, line protocol is up
  Internet Address 192.168.200.2/24, Area 0
  Process ID 2, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:09
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

【R3のshowコマンド抜粋】

show running-config

R3#show running-config
Building configuration...

Current configuration : 1268 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
~~~省略~~~
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial3/0
 ip address 192.168.200.1 255.255.255.0
 ip ospf hello-interval 20
 ip ospf 3 area 0
 serial restart-delay 0
!
!
router ospf 3
 router-id 3.3.3.3
 log-adjacency-changes
!
no ip http server
ip forward-protocol nd
!
~~~省略~~~

show ip route

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.200.0/24 is directly connected, Serial3/0

show ip interface brief

R3#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet1/0            unassigned      YES unset  administratively down down
FastEthernet2/0            unassigned      YES unset  administratively down down
Serial3/0                  192.168.200.1   YES manual up                    up

show ip ospf interface

R3#show ip ospf interface
Serial3/0 is up, line protocol is up
  Internet Address 192.168.200.1/24, Area 0
  Process ID 3, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 20, Dead 80, Wait 80, Retransmit 5
    oob-resync timeout 80
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

【R1とR2がネイバーを築けていない問題の解答と解説】

第1回と第2回同様に、R1とR2のshow ip route、show ip interface briefコマンド
でインターフェイスのL1・L2の状態を確認すると、IPアドレスとインターフェイスの有効化
がされているので問題ありません。

次にshow ip ospf interfaceコマンドを確認してみます。両ルータともFa0/0で
OSPFが有効化されています。しかし、それぞれのコマンドの3行目を確認してみると、
R2ではエリアが0で正しくなっていますが、R1ではエリアが1となっていて両ルータで
エリア番号にずれが生じてしまっています。OSPFではエリア番号が一致していなければ
ネイバー関係を築けないため、これが原因であることが分かります。

R1のshow running-configでFa0/0を確認してみましょう。

interface FastEthernet0/0
 ip address 192.168.100.1 255.255.255.0
 ip ospf 1 area 1
 duplex auto
 speed auto

エリア番号が誤って設定されています。

【修正コマンド】

R1(config)#interface FastEthernet 0/0
R1(config-if)#ip ospf 1 area 0

【R2とR3がネイバーを築けていない問題の解答と解説】

今までと同様にR2とR3のS3/0インターフェイスのIPアドレスおよびインターフェイスの
有効化をshow ip interface briefコマンドなどで確認してみると、設定に問題は
ありません。

次にshow ip ospf interfaceコマンドを確認します。両ルータともにS3/0でOSPFが
有効化されていますが、R2の24行目、R3の7行目の部分のHelloインターバルとDeadインターバル
の数値が一致していません。OSPFではHelloインターバルとDeadインターバルが一致して
いなければネイバー関係を築くことができません。

R3のshow running-configでS3/0インターフェイスの設定を確認してみましょう。

interface Serial3/0
 ip address 192.168.200.1 255.255.255.0
 ip ospf hello-interval 20
 ip ospf 3 area 0
 serial restart-delay 0

コマンドではHelloインターバルを20秒に設定しています。Helloインターバルを変更すると、
Deadインターバルも自動的に4倍の秒数に変更されます。
そのため、R3のshow ip ospf interfaceコマンドの7行目のようにHelloインターバル20秒、
Deadインターバル80秒となります。

【修正コマンド】

R3(config)#interface Serial 3/0
R3(config-if)#no ip ospf hello-interval 20

新課程対応のCCNA対策講座 連載リンク

ネットワーク学習の登竜門・・
ゼロからのCCNA独学講座

Recent News

Recent Tips

Tag Search