【CCNA新試験対策】トラブルシューティング問題~DHCP、設定確認編~


DHCPトラブルシューティング問題

CCNAの試験では択一問題だけではなく、自身で実際にコマンドを実行して設定を確認し、
選択問題を回答するという形式の問題も出題されます。

そのため各プロトコルやネットワークの基礎についての理解はもちろんのことですが、
ルータやスイッチの設定を読み取り、その設定が正しいor誤っているのか、
誤っている場合はどのように修正すれば良いのか、といったところまで深く理解しておく必要があります。

今回はICND1の試験範囲であるDHCPについて学んでいきたいと思います。
※DHCPの基本的な動作に関しては説明しませんのでご了承ください。

前回まででDHCPの設定を行いましたので、今回はDHCPの確認コマンドを見ていきましょう。
DHCPの構成図は以下のようになっています。
(クリックで別ウィンドウで拡大画像が表示されます。)

前回行った設定は以下の通りです。
Router1の設定

Router1#configure terminal
Router1(config)#interface FastEthernet 0/0
Router1(config-if)#ip address dhcp
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#interface FastEthernet 1/0
Router1(config-if)#ip address 192.168.10.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#ip helper-address 192.168.100.1
Router1(config-if)#exit
Router1(config)#exit
Router1(config)#

Router2の設定

Router2#configure terminal
Router2(config)#interface FastEthernet 0/0
Router2(config-if)#ip address 192.168.100.1 255.255.255.0
Router2(config-if)#no shutdown
Router2(config-if)#exit
Router2(config)#ip dhcp pool PC-NETWORK
Router2(dhcp-config)#network 192.168.10.0 255.255.255.0
Router2(dhcp-config)#default-router 192.168.10.1
Router2(dhcp-config)#exit
Router2(config)#ip dhcp pool ROUTER-NETWORK
Router2(dhcp-config)#network 192.168.100.0 255.255.255.0
Router2(dhcp-config)#exit
Router2(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.100
Router2(config)#ip route 192.168.10.0 255.255.255.0 FastEthernet 0/0
Router2(config)#exit
Router2#

DHCPの設定確認コマンド①show running-config

まず#show runから確認しましょう。設定が#show runのどの辺りに記載されているかも覚えておくと
便利ですので併せて覚えてください。

まずRouter1で確認します。Router1ではインターフェイスにしかDHCPの設定をしていませんので、
その部分のみ抜粋します。

Router1#show running-config
~~省略~~
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.10.1 255.255.255.0
 ip helper-address 192.168.100.1
 duplex auto
 speed auto
!

4行目にDHCPクライアントの設定、10行目にヘルパーアドレスの設定が記載されています。

次にRouter2で確認します。Router2のDHCPサーバの設定はshow runの上の方に載っています。
(インターフェイスのIPアドレスややルーティングの設定はDHCPとは関係ないため省略します。)

Router2#show running-config
~~省略~~
ip dhcp excluded-address 192.168.10.1 192.168.10.100
!
ip dhcp pool PC-NETWORK
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
!
ip dhcp pool ROUTER-NETWORK
   network 192.168.100.0 255.255.255.0
!

プールが2つ作成されていること、除外アドレスの設定がされていることが確認できます。

DHCPの設定確認コマンド②show ip dhcp binding、show ip dhcp pool

次にDHCPサーバの確認コマンドを見てみます。
#show ip dhcp bindingはDHCPによるIPアドレスの割り当てを、#show ip dhcp poolは作成されている
プールをそれぞれ確認することができます。
順番に見てみましょう。

Router2#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
192.168.10.101      0100.abb3.dba8.00       Mar 02 2002 12:02 AM    Automatic
192.168.10.102      0100.abbf.5b61.00       Mar 02 2002 12:02 AM    Automatic
192.168.100.2       0063.6973.636f.2d63.    Mar 02 2002 12:02 AM    Automatic
                    6330.302e.3033.3538.
                    2e30.3030.302d.4661.
                    302f.30

IPアドレス欄には割り当てたIPアドレスが、Client-ID/…欄にはIPアドレスを割り当てた機器の
MACアドレスなど
が表示されます。Lease expiration欄には割り当てる日数が表示されます。

Router2#show ip dhcp pool

Pool PC-NETWORK :
 Utilization mark (high/low)    : 100 / 0
 Subnet size (first/next)       : 0 / 0
 Total addresses                : 254
 Leased addresses               : 2
 Pending event                  : none
 1 subnet is currently in the pool :
 Current index        IP address range                    Leased addresses
 192.168.10.103       192.168.10.1     - 192.168.10.254    2

Pool ROUTER-NETWORK :
 Utilization mark (high/low)    : 100 / 0
 Subnet size (first/next)       : 0 / 0
 Total addresses                : 254
 Leased addresses               : 1
 Pending event                  : none
 1 subnet is currently in the pool :
 Current index        IP address range                    Leased addresses
 192.168.100.3        192.168.100.1    - 192.168.100.254   1

作成されているプールの詳細情報が確認できます。各プールの一番下の行だけ読み取れれば良いでしょう。
Current index欄には次にDHCPクライアントから要求があった際に割り当てるIPアドレスが記載されます。
IP address range欄にはプールのアドレスの範囲が、Leased addresses欄にはDHCPクライアントに
割り当てる期間
が記載されます。

DHCPの設定確認コマンド③show interfaces、show ip interface brief

ルータがDHCPクライアントとなっている場合、割り当てられたIPアドレスは#show runでは
確認することができません。そのためインターフェイスの設定を確認するコマンドでIPアドレスを
調べる必要があります。
Router1でそれぞれ確認してみましょう。

Router1#show interfaces FastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is cc00.0358.0000 (bia cc00.0358.0000)
  Internet address is 192.168.100.2/24
~~~省略~~~

4行目にIPアドレスが表示されています。

Router1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.100.2   YES DHCP   up                    up  
FastEthernet1/0            192.168.10.1    YES manual up                    up

3行目でFa0/0のIPアドレスが表示されます。またMethod欄でIPアドレスが設定された方法が記載されています。

今回はDHCPの設定を確認しました。ここまでの2回の記事を踏まえて、次回はDHCPトラブルシューティング問題
を行っていきます。

  • このエントリーをはてなブックマークに追加

PAGE TOP