【CCNA新試験対策】トラブルシューティング問題~DHCP、基本設定編~


DHCPトラブルシューティング問題

CCNAの試験では択一問題だけではなく、自身で実際にコマンドを実行して設定を確認し、
選択問題を回答するという形式の問題も出題されます。

そのため各プロトコルやネットワークの基礎についての理解はもちろんのことですが、
ルータやスイッチの設定を読み取り、その設定が正しいor誤っているのか、
誤っている場合はどのように修正すれば良いのか、といったところまで深く理解しておく必要があります。

今回はICND1の試験範囲であるDHCPについて学んでいきたいと思います。
※DHCPの基本的な動作に関しては説明しませんのでご了承ください。

DHCPのキホン構成例

以下の簡単な構成でDHCPの設定コマンドを確認していきましょう。
(クリックで別ウィンドウで拡大画像が表示されます。)

この構成の要件は以下のようにします。

・Router2をDHCPサーバとする。
・Router1のFa0/0はDHCPクライアントとしてDHCPサーバであるRouter2からIPアドレスが割り当てられている。
・PC-AとPC-BもDHCPクライアントとなっていて、同じくDHCPサーバであるRouter2からIPアドレスが割り当てられている。
・そのためRouter1のFa1/0にDHCPリレーエージェントの設定(ヘルパーアドレス)がされている。
・PC-AとPC-BのデフォルトゲートウェイはRouter1のFa0/1(IP:192.168.10.1)が割る当てられるように設定されている。
・192.168.10.0/24のネットワークには192.168.10.1~192.168.10.100までが割り当てられないように除外されている。

では、実際に設定してみます。

DHCPのキホン設定例

まず、Router1からの設定していきます。

Router1#configure terminal
Router1(config)#interface FastEthernet 0/0
Router1(config-if)#ip address dhcp
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#interface FastEthernet 1/0
Router1(config-if)#ip address 192.168.10.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#ip helper-address 192.168.100.1
Router1(config-if)#exit
Router1(config)#exit
Router1(config)#

各行を見ていきましょう。

2~5行目

Fa0/0の設定をしています。Router1のFa0/0はDHCPクライアントとしてIPアドレスを割り当てられるため、
ip address dhcpというコマンドを設定
しています。
CiscoルータをDHCPクライアントとして動作させるためには、インターフェイス単位でこのコマンドを設定する
必要があります。

6~9行目

Fa1/0の設定をしています。こちらはDHCPクライアントになっていませんので手動でアドレスを設定しています。
ただし、PC-AとPC-Bから送信されるDHCP DISCOVERのメッセージをDHCPサーバまで届ける必要があるため、
ヘルパーアドレスの設定がされています。

次に、Router2の設定を見ていきます。

Router2#configure terminal
Router2(config)#interface FastEthernet 0/0
Router2(config-if)#ip address 192.168.100.1 255.255.255.0
Router2(config-if)#no shutdown
Router2(config-if)#exit
Router2(config)#ip dhcp pool PC-NETWORK
Router2(dhcp-config)#network 192.168.10.0 255.255.255.0
Router2(dhcp-config)#default-router 192.168.10.1
Router2(dhcp-config)#exit
Router2(config)#ip dhcp pool ROUTER-NETWORK
Router2(dhcp-config)#network 192.168.100.0 255.255.255.0
Router2(dhcp-config)#exit
Router2(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.100
Router2(config)#ip route 192.168.10.0 255.255.255.0 FastEthernet 0/0
Router2(config)#exit
Router2#

こちらも設定を確認していきます。

2~5行目

Fa0/0の設定です。IPアドレスを設定しているだけです。

6~9行目

DHCPサーバとしてIPアドレスを割り振るDHCPプールの設定をしています。PCが所属するネットワーク
192.168.10.0/24の設定をしています。PCにはデフォルトゲートウェイを割り当てる必要があるため、
default-routerコマンドの設定をしています。

10~12行目

ルータ間のネットワークである192.168.100.0/24のDHCPプールの設定をしています。こちらは
Router1のFa0/0にIPアドレスを割り振るだけですので、デフォルトゲートウェイの設定は特に
必要ありません。
※このように、DHCPサーバとして複数の異なるネットワークにIPアドレスを割り振る場合は、
ネットワークの個数だけDHCPプールを作成しなくてはなりません。

13行目

DHCPで割り振らない、除外アドレスの設定をしています。192.168.10.1から10.100までを除外する場合は
このような表記になります。開始アドレス、終了アドレスの順番でIPアドレスを記述します。
このコマンドはグローバルコンフィグレーションモードで設定をするという事に注意してください。

14行目

DHCPの設定とは全く関係ないのですが、Router2ではルーティングの設定をしておかなければ
192.168.10.0/24ネットワークとは通信することができませんので設定しています。

今回は設定までとします。次回はDHCPの確認コマンドを見ていきます。
  • このエントリーをはてなブックマークに追加

PAGE TOP