ネットワーク問題 その6


ネットワークに関する問題を出題します。

インターネット接続するためのルータを設定することになりました。
以下の設定をCisco製ルータに投入したものの、一部のwebサイトが閲覧できなくなりました。

interface FastEthernet0
description ##### out side interface #####
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1

interface FastEthernet1
description ##### out side interface #####
ip address 192.168.100.1 255.255.255.0
ip nat inside

interface Dialer1
description ##### dialer interface #####
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname ********
ppp chap password 7 ********

ip nat inside source list 100 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

//
原因として考えられることを以下の中から選択して下さい。
1.DialerインターフェイスにIPアドレスを振っていない
2.NATの設定ではDialerインターフェイスではなくFastEthernet0を設定する
3.MTUやMSSの設定を行っていない
4.デフォルトルートの設定先が間違っている

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
答え 3
 PPPoEを使用する場合、LAN内で使用されているEthernetのフレーム(MTU:1500)をPPPoEでカプセル化する必要があるためPPPとPPPoEの分(合計8バイト)MTUのサイズを小さく設定する必要があります。
それにともないMSSのサイズも変更する必要があります。通常のEthernetフレームの場合、MTUサイズからIPヘッダとTCPヘッダのサイズを引いた1460ですが、さらにPPPoEとPPP分小さくします。
MTUが小さな回線を通る場合、パケットフラグメンテーションが行われ、それにより一部のサイトの閲覧ができなくなるといったことが起きることがあります。
NTTのフレッツに接続する場合などはさらに小さくMTUは1454、MSSは1414に設定する必要があります。
今回はVPNを使用していませんが、使用する場合はESPのヘッダーサイズなどを考えさらに小さくする必要があります。

  • このエントリーをはてなブックマークに追加

PAGE TOP